Features
Help
Get Windscribe
What is the minimum version of iOS needed to use Windscribe?

In order to use Windscribe on an iOS device, you need to be running a minimum of iOS 10 or above. However, keep in mind that certain application functions are available to higher versions of iOS.

For instance, in order to connect to Windscribe via the Wireguard protocol, your iOS device must be running iOS 12 or above. If you are unsure about the specifics of your Apple device, have a look at this help article: https://support.apple.com/en-us/HT201685

COMMUNITY
Talk to Garry
Feeling lost or lonely? Talk to Garry.
Get in touch
Windscribe
forground_icon© 2023 Windscribe Limited